Test: 7Links WLAN-IP-Kamera mit IR & Bewegungserkennung

7links-ipcam

Wer hat nicht schon mal mit dem Gedanken der Heim-Überwachung gespielt. Manchmal ist es auch ein ganz trivialer Anlass wie bei mir: Ein Marder trieb sein Unwesen in der Gegend und verwüstete meinen Motorraum. Die Viecher sind sehr territorial und das ist doof, wenn ein zweiter Marder ins Spiel kommt (z.B. wenn man bei der Freundin parkt). Das hat immerhin 180,- Euro gekostet und war somit kein Spaß.

Nun ja, damit man aber mal sieht, ob der dann nachgerüstete Marderschreck im Motorraum auch etwas bringt und er sich wirklich nicht mehr daran traut, ist solch eine WLAN-Kamera mit Nachtsicht und (bei Bewegung) automatischem Bildversand per E-Mail ideal geeignet Smilie: :-)

Gleich vorweg ein kleines Mini-Fazit

Die Kamera ist ihre aktuell 99 Euro wirklich wert, sie hat alles was man braucht. Allerdings muss einem bewusst sein, dass man ausschließlich über den Internet Explorer auf das Kamerabild und auch die Einstellungen zugreifen kann.

Marketing

Die Aussage “Zudem sorgen 10 Infrarot-LEDs absolut unauffällig für Licht im Dunkeln! ” finde ich etwas irreführend, da man die “Infrarot”-LEDs sehr wohl sehen kann, zudem blinkt eine weiße LED bei Aufnahme bzw. Bewegungserkennung in schnellem Rhythmus.

Auch die Aussage “Wird die Bewegungserkennung ausgelöst, verschickt die Kamera sofort eine E-Mail mit 2 Fotos.” trifft den Wahrheitsgehalt nur zu 33%, denn die Kamera verschickt (zum Glück) 6 Bilder im Abstand von ungefähr 1-2 Sekunden.

Über die Bildqualität lässt sich nicht meckern, einzig störend finde ich die nicht manuell nachstellbare Autofokussierung.

WLAN mit WPA2 ist zum Glück einwandfrei möglich, wie die Angaben auf der Herstellerseite suggerieren. Das einzige Manko: Sie ist zwar portabel, aber das Einstellen eines anderen WLAN-Netzes ist sehr kompliziert durchführbar und sollte am besten noch daheim erledigt werden, bevor man sie zum neuen WLAN-Netzwerk mitnimmt. Crossover-Patchkabel und Laptop nicht vergessen!

Das “User-Management mit Passwort-Schutz und verschiedenen Zugriffsebenen” ist prima.

Erste Probleme nach dem Firmware-Update (Mitte April)

Darstellungsfehler der Optionsfelder unter Audio/Video. Das sah dann so aus wie links zu sehen und war auch durch etliche Fenster-Verschiebungs-Versuche nicht wiederherzustellen. (Das blaue Band links ist der Browser-Rahmen)

Das einzige was half, war die Cam kurzzeitig auf 320×240 zu stellen, die gewünschten Optionen vorzunehmen (in meinem Fall spiegeln und umdrehen), und sie danach wieder auf 640 zu stellen.
Denn das blöde ist, dass sich die verkleinerte Ansicht z.B. am Rand des Bildschirms auch gleich auf die Kamera selbst auswirkt, d.h. sie sendet dann nur noch 320er-Screenshots, die natürlich viel zu klein sind.

Hier gibt es aktualisierte Firmware zum Download:
http://www.pearl.de/support/product.jsp?pdid=PX3309&catid=1120&nodocs=1

Unter diesem Link geht es zur Händler-Seite von Pearl.

Greetings,
Lessy

Update 10-07-25:

Habe endlich eine funktionierende Version eines Bild-Abrufs sogar mit JavaScript-Steuerung der Kamera zum Laufen bekommen. Das beste: Funktioniert sogar über Proxies (Firmen-Netzwerk) und in Firefox (!) Smilie: :-)

Hier ist alles Nötige enthalten: Download pearl-ipcam-JS-steuerung.zip.

Einfach die Cam-URL anpassen auf eure Bedürfnisse, schon klappt’s auch mit dem Nachbarn bzw. dessen Beobachtung Smilie: ;-)

Und so sieht’s dann aus:
pearl-ipcam-robocam-mit-javascript-steuerung

Update 10-07-27:

Habe nochmal ein wenig weitergebastelt und muss sagen, dass ich mit dem Ergebnis zufrieden bin: Nun kann ich endlich vom Handy aus immer ein aktuelles Bild abrufen und die Kamera fernsteuern. Ich habe die HTML-Datei zur Steuerung für Touchscreen-Handys optimiert, aber sie sollte auch bei normalen Handys funktionieren. Voraussetzungen sind entweder eine Website, auf die ihr die Bilder und die HTML laden könnt, oder ein Handy, das lokale HTML-Dateien aufrufen kann. Zusätzlich wird JavaScript benötigt. Auch hier kann man wieder auf das Bild “klicken”, um die Originalgröße (640×480) aufzurufen, um mal eben ein paar Details zu erkennen. Des Weiteren ist auch die Autoscan-Funktion aufrufbar (Doppelpfeil) sowie wieder stoppbar und ein manuell gewünschter Reload des Bildes möglich (Refresh-Pfeile).

Bei meinem Android sieht das dann so aus:
htc-g1-mit-android-und-ipcam-steuerunghtc-google-g1-mit-android-und-ipcam-steuerung_overlay

Nach einem Klick/Touch auf einen jeweiligen Steuerpfeil kommt ein Overlay mit Informationen und die Seite wird nach 2 Sek. neu geladen. Das ist leider nötig, da jedenfalls unter Android der Browser sonst dem Cam-Steuerlink-Aufruf nicht genug Zeit zur Ausführung lässt. So klappt’s aber auf jeden Fall Smilie: :)

In dem folgenden ZIP (80KB) sind die nötigen Bilder und die HTML enthalten: webcam-handy-touch.zip
Ihr müsst lediglich eure Cam-URL anpassen (Suchen & ersetzen).

Viel Spaß!

PS: Es handelt sich hier übr. um eine PTZ-Kamera, was soviel heißt wie Pan-Tilt-Zoom. Wobei Zoom auf unser Modell hier nicht zutrifft.

Update 10-08-01:

Auf Nutzer-Request wurde die vom Handy aus steuerbare Version noch um eine Video-Variante erweitert.
Im o.g. ZIP-file (80KB) sind ist nun auch die Video-Version enthalten: webcam-handy-touch.zip

Update 12-03-24:

Dank des ambitionierten Nutzers “Punkt6″ haben wir hier die Möglichkeit, evtl. beim Flashen kaputt gegangene Cams wiederzubeleben.
Benötigte Files:
linux.zip
romfs.img

Detaillierte Anleitung:

Hyperterminal Verbindung über RS232 – 3,3 Volt –> ich hab ein altes Siemens Handykabel verwendet.
Von oben gesehen:
RX, TX, GND, 3,3V
Eventuell RX und TX vertauschen, je nach Kabel.
Danach während des Bootens der Cam ESC drücken (Camera einstecken und ESC)
Bildschirm der zu sehen sein sollte:
Copyright (c) Winbond Limited 2001 - 2006. All rights reserved.
Boot Loader Configuration:

MAC Address : XX:XX:XX:XX:XX:XX
IP Address : 0.0.0.0
DHCP Client : Enabled
CACHE : Enabled
BL buffer base : 0x00300000
BL buffer size : 0x00100000
Baud Rate : 115200
USB Interface : Enabled
Serial Number : 0x00XXXXXXX

For help on the available commands type ‘h’
Press ESC to enter debug mode .

bootloader >
Befehl:
LS Anzeigen
bootloader > LS
Danach werden die Speicherbereiche der einzuspielenden Dateien angezeigt….
Image: 0 name:BOOT INFO base:0x7F010000 size:0x00000048 exec:0x7F010000 -f
Image: 7 name:linux.bin base:0x7F020000 size:0x000BB32C exec:0x00008000
-acxz
Image: 6 name:romfs.img base:0x7F0E0000 size:0x0008D000 exec:0x7F0E0000 -a
Mit del wird gelöscht – aber nur 7 und 6!!!
Del 7
Del 6
Danach die Dateien einspielen:
fx 7 linux.zip 0x7f020000 0×8000 ­acxz
Menü Transfer ­ Send File ­ Datei linux.zip auswählen ­ Protokoll XModem

fx 6 romfs.img 0x7f0e0000 0x7f0e0000 ­a
Menü Transfer ­ Send File ­ Datei romfs.img auswählen ­ Protokoll XModem

Nach Beenden des Uploades – versuch die Cam zu starten:
bootloader> boot

Jetzt sollte die Cam über das IP Camera Tool zu sehen sein. Von hier aus kann die GUI geflasht werden (rechte Maustaste). Viel Erfolg! Hat bei meiner PX-3309 einwandfrei geklappt….

Mfg
Punkt6

Update 13-12-01:

Dank Punkt6 können wir hier nun auch die Firmware-Files für die PX3615 anbieten:
Firmware: PX3615 Fw (1.67MB)
Und hier noch das nötige Toolkit für die Extraktion von Firmware und WebGUI: IPCam-Toolkit (140KB)
Danke!

Update 13-12-09:

Polling hat die Kamera nun auch im Angebot, allerdings mit besserer Auflösung und nativer Smartphone-App für 80 Euro (nur heute!): pollin.de/shop/dt/NzczNzcyOTk-/Computer_und_Zubehoer/Multimedia/Kameras/HD_IP_Kamera_PREMIUMBLUE_PIPC_HD720SD_Pan_Tilt.html

Kategorie(n): Produkt-Tests
Tags: , , , , , , , , , , , ,

294 Antworten auf Test: 7Links WLAN-IP-Kamera mit IR & Bewegungserkennung

    Daytrader sagt:

    Hallo zusammen,
    habe mir im April eine Pearl 7LINK Kamer PX 3615 gekauft.
    Folgende Probleme treten auf:

    Kein E-Mailversand bei Alarmfall obwohl alles richtig konfiguriert ist und der Test positiv verläuft.

    Auch die Speicherpfade für Aufnahmen lassen sich nicht ändern. Welche Schritte muss ich vornehmen? Danke.

    • Hallo,
      habe die PX 3671 angeschafft und die nach langen Recherchen allein korrekt einrichten können. So lief sie dann monatelang bis Ende März d. J. – Dann ging (ohne Änderungen) gar nichts mehr. Irgendwo las ich dann von der SSL – Umstellung der Mailserver, die Anpassungen erfordern sollten. Letztere nahm ich ohne Erfolg vor. Nachdem ich schließlich auch meinen kostenpflichtigen Mailaccount ohne Erfolg probiert hatte, telefonierte ich mit GMX. Hier erhielt ich den Tipp, ggf. den Port (auf 465) zu ändern, weil die Einträge in der Datenbank bei uralten Mailkonten evtl. nicht stimmen könnten und schließlich Keiner wissen könne, wie das Mailkonto ursprünglich konfiguriert wurde. Also habe ich nochmal alle nur möglichen Einstellungs – Kombis aus Protokoll (STARTTLS, TLS; KEINS) und Port (587, 465, 25) durchprobiert. Das alles für 3 ältere Mailkonten (GMX, kostenpflichtig, GMX Free und 1 und 1) und ohne Erfolg. Dann dachte ich, lege ich mir eben eine neues GMX – Konto zu. Das funktionierte auch nicht (weder POP 3, noch IMAP). Gelesen hatte ich, dass die Umstellung bei sämtlichen Mailanbietern (GMX, 1 und 1, Schlund und Partner – klar, die gehören zusammen! – Web.de, Telekom…Smilie: ;) erfolgen sollte.
      Das Problem konnte ich wie folgt lösen:
      1. Neue Google – Mailadresse (Imap) angelegt
      2. Mailadresse in den Client (Thunderbird) eingetragen. Also so: yz@gmail.com">xyz@gmail.com
      Posteingangsserver: imap. googlemail.com, Port 993,
      Protokoll: SSL/TLS, Password: normal

      Postausgangsserver: smtp.googlemail.com, Port 465
      Protokoll: SSL/TLS, Password: normal
      3. In der UI der Cam unter Maileinstellungen:
      Sender: die Googlemail – Adresse (xyz@gmail.com)
      Empfänger: wie Sender, also dieselbe Adresse

      Jetzt funktionierts!

      Zuvor hatte ich als Sender abc@gmx.de und als Empänger def@gmx.de (also zwei unterschiedliche Pop 3 – Konten) und jedes davon mit
      denselben Einstellungen: Posteingang: pop.gmx.net, Port 995
      Protokoll: STARTLS, Password: normal –
      Postausgang: mail.gmx.net, Port 587
      Protokoll: STARTLS, Password: normal
      Als meine AV – Software begann, die Mails zu prüfen, musste ich das (nur für den Posteingang) anpassen: das Protokoll hieß dann (KEINES) und die anderen Einstellungen in Thunderbird blieben.

      Wie gesagt, auch das funktionierte viele Monate lang wunderbar. Weil die Probleme Ende März auftraten und die Umstellung der Server bei den meisten Anbietern Anfang April greifen sollte, nehme ich an, dass es damit zu tun hatte. Weshalb allerdings keine der Kombinationen aus Port und Protokoll funktionierte, ist mir noch immer ein Rätsel. Die fehlermeldung “Fehler” auf eine Testmail bei Port 25 und Protokoll: KEINES ist logisch, weil der Server ablehnt, wenn kein Verschlüsselungsprotokoll angegeben (also nicht verschlüsselt) wird. Warum aber bei jeder der anderen Kombinationen “Serverfehler” erschien, obwohl GMX, wie ich nachgelesen hatte das SSL auf allen drei Ports verwenden kann, na ja, das bleibt wohl ein Rätsel.
      Vielleicht wurde die Sache ja so sicher gemacht, dass jetzt nichts mehr geht?

    • Speicherpfad festlegen:
      Hatte nach dem Umstieg von XP auf Win7 dasselbe Problem. Die Kamera wollte partout im öffentlichen Ordner speichern, was ich nicht wollte.
      Ich wollte Ordner auf einer anderen Partition bzw. Festplatte.
      Bei Windows 7 müssen die angelegten Ordner explizit freigegeben werden. z.B.
      Festplatte/ Partition auf der der leere Speicherordner angelegt ist auswählen, dann den Ordner markieren und im Menü auf “Freigeben für” klicken. Hier auswählen, für WEN der Ordner freigegeben werden soll (ist komplizierter) oder (einfacher) für das Heimnetz (Lesen /Schreiben) freigeben.
      Danach kommt ggf. ein Hinweis darauf, dass der Ordner(für erleichterte Suche) indiziert ist. Das lässt sich unter Systemsteuerung ändern. (Wer das will, sucht am Einfachsten in der Hilfe nach Index bzw. Indizierung und folgt der kurzen Anweiseung.)

      Wenn diese Vorgehenseweise nichts bringt und sich der Pfad noch immer nicht ändern lässt, kann man Folgendes probieren:
      Internetexplorer öffnen, Menü Extras, Interneteinstellungen, Sicherheit.
      Letztere wie zur Installation der Active X – Komponenten einstellen und dabei darauf achten, dass der Haken unter “Geschützten Modus verwenden” entfernt wird.
      Dann IE schließen und erneut öffnen. Jetzt den Pfad ändern, die Einstellung speichern und IE schließen. Internetexplorer beim nächsten Start natürlich wieder auf die sicheren Einstellungen zurücksetzten (reparieren).
      Bei mir funktionierte es nur auf diese Weise und auch erst, nachdem ich die Ordner wie o.a. freigegeben hatte.

    Alfred Forster sagt:

    Vielen Dank für die Antworten

    @Lestarte: SSID manuell hat bei mir nicht geholfen

    @Tanya: Kamera reset hat nicht geholfen. Wenn ich LAN Kabel wegnehme, kriege ich vom IP Kamera Tool keine IP mehr geliefert. Und wie gesagt, im LAN-Betrieb bei “WLAN -> scannen” kommt nichts, obwohl ich einen Infrastucture Router (was ja entgegen dem Handbuch der normale AP ist), wie einen AdHock Router in Betrieb habe.

    Ich habe hier noch einen Firmware und einen Web UI Update gefunden:

    http://www.2shared.com/file/O7p5qD8t/Firmware-Update_PX-3615.html

    Leider auch damit kein WLAN Betrieb möglich.

    Gegenüber dem Pearl Update habe ich wenigsten 2 Verbesserungen:

    1. Die Funktion “voreingestellte Position speichern/abrufen” ist vorhanden, funktioniert aber nicht korrekt.

    2. Ich kann die beiden Aufnahme Pfade setzen

    Ich habe nun einen weiteren PX-3615 bestellt und werde den andern zurück senden.

    LG Alfred

  1. @Alfred

    Also ich glaube dir, mir ist nämlich genau dasselbe passiert. Also, ich hab mal die Cam resetet, dann war das bei mir anfangs so, dass über Lan ich die IP ….39 hatte und über WLAN die IP …..40. Nach dem “Update” und dem Reset, lief WLAN über die IP ….39. Ach ja und ich habe noch eine Systemwiederherstellung gemacht, die ja aber vermutlich keinen Sinn gemacht hat. Ich glaub das war’s. Dann liefs wieder und ich mache nie mehr ein Udate…
    Tanya

  2. @Alfred: Leider nein, ausser halt per Kommentar Smilie: ;) Und wenn Du die SSID und Pwd manuell einträgst? Hilft meistens. Firmwares: Leider keine Ahnung…

    Alfred Forster sagt:

    ok, Hier meine Story:

    PX-3615 gekauft, mit LAN und WLAN bestens funktioniert (nur lokaler Zugriff).

    Dann gedacht, ein Update von der PEARL-Support Seite kann ja nichts schaden, Firmware und WebUI installiert…

    und oh Schreck..WLAN funktioniert nicht mehr, schon scannen zeigt mir meine SSID nicht mehr.

    Mit Pearl Support (Deutschland und Schweiz)telefoniert…die glauben mir die Story nicht.

    Die original Firmware Version 17.37.2.41 sollte doch irgendwo verfügbar sein, auch die original Web UI Version (die ich leider nicht aufgeschrieben habe).

    Vielen Dank für Antworten.

    Alfred

    • Crash – Firmwareupdate –
      Hatte ich auch schon. Da hilft:
      a) Nachsehen ob andere Händler des Modells ggf. irgendwo Firmware in’s Netz gestellt haben und die testen, oder
      b) die alte Firmware von der CD verwenden bis man fündig wird.

      Web UI:
      Wie die ursprünglich hieß, dürfte auch auf der CD zu sehen sein.

      Firmware – Update
      Dabei soll es ganz wichtig sein, die ursprüngliche Version (auf der CD) zu beachten. Wenn die z.B. 17.37.2.41 ist, dann kann für das Modell jede Firmwareversion benuzt werden, die mit 17.37.2 beginnt, also z.B. 17.37.2.104. – Nicht verwenden könnte man dagegen 17.40.2. 41.
      Wichtig soll sein, dass die ersten drei Blöcke genau mit der ursprünglichen Firmware übereinstimmen. Der 4. Block soll egal sein.
      Diese Info hatte ich (nach dem Crash) einst auf einer Experten – Site gefunden und auch mit Erfolg ausprobiert. Dort war man sogar der Ansicht, dass die Marke – wegen zahlreicher baugleicher Modelle – wohl kaum eine Rolle spielen dürfte. (Das habe ich aber nicht ausprobiert. Ich blieb bei der Firmware für 7 Links. – schließlich wird auch diese marke noch von anderen Händlern vertrieben.)

    Alfred Forster sagt:

    Hallo

    Kann ich hier auch posten?

  3. Ok. Danke. Ich versuch das dann mal…

  4. Das wurde aber eigentlich schon hinlänglich erwähnt: Stichwort DynDNS Smilie: :) http://lmgtfy.com/?q=dyndns

  5. Danke für deine Antwort. Nun hatte ich gestern mal eine Verbindung zur Cam vom IPhone aus. Heute gehts zwar wieder nicht, aber was mich noch viel mehr interessieren würde, wie kann ich von ausserhalb meines Netzwerks vom PC aus auf die Cam zugreifen, weil ich ja über die IP-Adresse reinkomme. Ausserhalb meines Netzwerks geht das ja dann nicht mehr und ich würde ja vor allem von ausserhalb auf die Cam zugreifen wollen und nicht wenn ich eh zu Hause bin.
    Bitte in möglichst einfachen Worten, bin nicht so ein Crack Smilie: ;-)
    Danke.

  6. Also manchmal geht das auch bei mir nicht, aber meist hilft ein Neustart der Cam weiter. Wenn ansonsten alles passt und Du die Cam schon mal am Phone sehen konntest, dann passt ja anscheinend auch alles mit der DynDNS. Falls nicht, würd ich mal bei dem DynDNS ansetzen – bis es da mal alles richtig klappt, dass die “Domain” wirklich durchkommt zu Deiner IP, das kann nervig sein… Kannst Du mal eben einen Apache einrichten und die Cam ausscahlten? Dann könntest Du nämlich nach Eingabe der DNS-Domain sehen, ob Du überhaupt durchkommst…

  7. Hallo
    Ich habe eine IPC-710IR. WLAN funktioniert einwandfrei. Nun mein Problem. Wie schaffe ich es, von auswärts (ausserhalb meines Netzwerks) auf die Cam zuzugreifen?
    Auf dem IPhone funktioniert die App auch nicht wie sie sollte. Da lädt und lädt es nur, bis dann ein Balken angezeigt wird, aber kein Bild.
    Vielen Dank schon mal! Bin schon am verzweifeln.
    LG Tanya

  8. Hi. Da bleiben dir wohl nur zwei Optionen: Einschicken oder die von Punkt6 gestrickte Lösung versuchen.

    Stefan_vlbg sagt:

    Hallo Zusammen,

    Ich hab ein Promblem mit meiner PX-3309 und zwar:

    Gestern hab ich die Cam mit der Orginalsoftware (von Pearl.de) geflasht und nun, oh Schreck, die Cam reagiert nicht mehr wenn ich das NT einsteck Smilie: :-(
    Die Stromversorgung ist aber iO – LED’s der Ethernetbuchse blinken Smilie: ;-)

    nun meine Frage: Gibt es irgend einen Trick od. Tipp das sie wieder Funktioniert?

    Danke im Voraus
    LG Stefan

  9. Ist bereits live, schau oben unter UPDATE Smilie: :)

  10. Hast Du eine feste IP vergeben oder auf DHCP? Würde eine feste vergeben. Die WLAN-Einstellungen hab ich schon lange nicht mehr angesehen, glaube aber, dass man bei der SSID auf Groß-Kleinschreibung achten musste…

    christodan sagt:

    Hallo,
    bei mir liegt auch noch eine verflashte PX3615. Ich bitte auch um die Files und Anleitung. Und: wie heiß das kabel?
    Danke im Voraus!

    Christoph

  11. Hallo,
    ich weiss ich bin fast zwei Jahre zu spät. Aber habe mir bei Pearl letzte Woche eine IP Cam von 7links (PX3614) gekauft. Im LAN Funktioniert alles einwandfrei. Ich kann jedoch mein Wlan Netzwerk nicht finden und wenn ich die Angaben manuell mache und die cam dann ohne Netzwerkkabel starte schaltet sie sich die ganze zeit ein und aus aber ist nicht im Netzwerk zu erkennen.
    Kann mir eventuell jemad weiterhelfen?

    Gruss

    Marc

    tommi.e sagt:

    … Danke …! Smilie: :)

  12. Hallo,

    ich hab eine Anleitung für den Vorgang an Lestarte gesendet (inkl. der benötigen Files für eine PX3309). Bei bedarf kann ich mitlerweile auch die romfs,img und die linux.zip für eine PX3615 liefern.

    Gruß
    Punkt6

  13. Hello All, ich bin auch noch an einer Beschreibung, und Files interessiert um die Kamera von der falschen Firmware zu befreien. Momentan ist die Kamera nur ein Stück IT Schrott und wartet auf ein neues Leben.

6 Reaktionen in anderen Blogs/Artikeln

Hinterlasse eine Antwort

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *

CAPTCHA-Bild

*

 

Du kannst folgende HTML-Tags benutzen: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>